<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
    <title>Nairobi Diaries star Mishi Dora mourns death of partner - Zipo.co.ke</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://zipo.co.ke/xmlrpc.php" />
    <meta property="og:image" content="http://zipo.co.ke/wp-content/uploads/2018/01/Mishi-Dora_BUZZCENTRAL.jpg" /><meta name="author" content="PulseLive">
<link rel="icon" type="image/png" href="http://zipo.co.ke/wp-content/uploads/2017/10/zpfav.png">
<!-- This site is optimized with the Yoast SEO plugin v6.3.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="news_keywords" content="mishi dora, k24, nairobi diaries, accidents in kenya" />
<link rel="original-source" href="http://zipo.co.ke/31000/nairobi-diaries-star-mishi-dora-mourns-death-partner/" />
<link rel="canonical" href="http://zipo.co.ke/31000/nairobi-diaries-star-mishi-dora-mourns-death-partner/" />
<link rel="publisher" href="https://plus.google.com/b/105677568423116486640/105677568423116486640/about?gmbpt=true&#038;hl=en"/>
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Nairobi Diaries star Mishi Dora mourns death of partner - Zipo.co.ke" />
<meta property="og:description" content="Nairobi Diaries actress and socialite Mishi Dora is a sad woman after she lost her business partner and best friend in a nasty road accident. According to Mishi who shared the news on her Instagram page, she was supposed to meet Brax her business partner who was also her hair dresser either on Wednesday or &hellip;" />
<meta property="og:url" content="http://zipo.co.ke/31000/nairobi-diaries-star-mishi-dora-mourns-death-partner/" />
<meta property="og:site_name" content="Zipo.co.ke" />
<meta property="article:publisher" content="https://www.facebook.com/zipo.co.ke" />
<meta property="article:tag" content="Accidents in Kenya" />
<meta property="article:tag" content="K24" />
<meta property="article:tag" content="Mishi Dora" />
<meta property="article:section" content="Entertainment" />
<meta property="article:published_time" content="2018-03-14T13:16:29+03:00" />
<meta property="article:modified_time" content="2018-03-14T13:29:59+03:00" />
<meta property="og:updated_time" content="2018-03-14T13:29:59+03:00" />
<meta property="fb:app_id" content="1399577056735104" />
<meta property="og:image" content="http://zipo.co.ke/wp-content/uploads/2018/01/Mishi-Dora_BUZZCENTRAL.jpg" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="469" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Nairobi Diaries actress and socialite Mishi Dora is a sad woman after she lost her business partner and best friend in a nasty road accident. According to Mishi who shared the news on her Instagram page, she was supposed to meet Brax her business partner who was also her hair dresser either on Wednesday or [&hellip;]" />
<meta name="twitter:title" content="Nairobi Diaries star Mishi Dora mourns death of partner - Zipo.co.ke" />
<meta name="twitter:site" content="@zipo_co_ke" />
<meta name="twitter:image" content="http://zipo.co.ke/wp-content/uploads/2018/01/Mishi-Dora_BUZZCENTRAL.jpg" />
<meta name="twitter:creator" content="@zipo_co_ke" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/zipo.co.ke\/","name":"Zipo.co.ke","potentialAction":{"@type":"SearchAction","target":"http:\/\/zipo.co.ke\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Zipo.co.ke &raquo; Feed" href="http://zipo.co.ke/feed/" />
<link rel="alternate" type="application/rss+xml" title="Zipo.co.ke &raquo; Comments Feed" href="http://zipo.co.ke/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Zipo.co.ke &raquo; Nairobi Diaries star Mishi Dora mourns death of partner Comments Feed" href="http://zipo.co.ke/31000/nairobi-diaries-star-mishi-dora-mourns-death-partner/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/zipo.co.ke\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='font-awesome-css'  href='http://zipo.co.ke/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='http://zipo.co.ke/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.11.2' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto_cond-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A400%2C300%2C700%2C700italic%2C400italic%2C300italic&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://zipo.co.ke/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://zipo.co.ke/wp-content/themes/Newsmag/style.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript' src='http://zipo.co.ke/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://zipo.co.ke/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://zipo.co.ke/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://zipo.co.ke/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://zipo.co.ke/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.4" />
<link rel='shortlink' href='http://zipo.co.ke/?p=31000' />
<link rel="alternate" type="application/json+oembed" href="http://zipo.co.ke/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fzipo.co.ke%2F31000%2Fnairobi-diaries-star-mishi-dora-mourns-death-partner%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://zipo.co.ke/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fzipo.co.ke%2F31000%2Fnairobi-diaries-star-mishi-dora-mourns-death-partner%2F&#038;format=xml" />
<link rel='https://github.com/WP-API/WP-API' href='http://zipo.co.ke/wp-json' />
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://zipo.co.ke/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://zipo.co.ke/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="amphtml" href="http://zipo.co.ke/31000/nairobi-diaries-star-mishi-dora-mourns-death-partner/amp/">
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="http:\/\/zipo.co.ke\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=3.1";
var td_get_template_directory_uri="http:\/\/zipo.co.ke\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-76223735-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-76223735-1');
</script><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6709196930072417",
    enable_page_level_ads: true
  });
</script>

</head>

<body class="post-template-default single single-post postid-31000 single-format-standard nairobi-diaries-star-mishi-dora-mourns-death-partner wpb-js-composer js-comp-ver-4.12 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-151" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-151"><a href="http://zipo.co.ke/category/news/">LATEST NEWS</a></li>
<li id="menu-item-864" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-864"><a href="http://zipo.co.ke/category/entertainment/">ENTERTAINMENT NEWS</a></li>
<li id="menu-item-12362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12362"><a href="http://zipo.co.ke/category/entertainment/music/">MUSIC</a></li>
<li id="menu-item-291" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-291"><a href="http://zipo.co.ke/contact-us/">Drop us a line..</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://zipo.co.ke/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap">
    
        <div class="td-outer-container">
        
            <!--
Header style 5
-->
<div class="td-header-wrap td-header-style-5">
    <div class="td-top-menu-full">
        <div class="td-header-row td-header-top-menu td-make-full">
            <!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap">
        <div class="td-header-row td-header-main-menu">
            <div class="td-make-full">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://zipo.co.ke/">
			<img src="http://zipo.co.ke/wp-content/uploads/2016/02/zpmb.png" alt=""/>
		</a>
				<a class="td-header-logo td-sticky-header" href="http://zipo.co.ke/">
				<img src="http://zipo.co.ke/wp-content/uploads/2016/08/zpmbw.png" alt=""/>
				<span class="td-visual-hidden">Zipo.co.ke</span>
			</a>
		    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-151"><a href="http://zipo.co.ke/category/news/">LATEST NEWS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-864"><a href="http://zipo.co.ke/category/entertainment/">ENTERTAINMENT NEWS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-12362"><a href="http://zipo.co.ke/category/entertainment/music/">MUSIC</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-291"><a href="http://zipo.co.ke/contact-us/">Drop us a line..</a></li>
</ul></div></div>

<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://zipo.co.ke/">
				<div role="search" class="td-head-form-search-wrap">
					<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-header-container">
        <div class="td-header-row td-header-header">
            <div class="td-header-sp-rec">
                
<div class="td-header-ad-wrap  td-ad-m td-ad-tp td-ad-p">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1024 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="1246540727"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
                    if ( td_screen_width >= 768  && td_screen_width < 1024 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="1246540727"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:100px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="1246540727"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 



</div>            </div>
        </div>
    </div>
</div>
    <div class="td-container td-post-template-default">
        <div class="td-container-border">
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    

    <article id="post-31000" class="post-31000 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-accidents-in-kenya tag-k24 tag-mishi-dora" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header td-pb-padding-side">
            
            
<p id="breadcrumbs"><span xmlns:v="http://rdf.data-vocabulary.org/#"><span typeof="v:Breadcrumb"><a href="http://zipo.co.ke/" rel="v:url" property="v:title">Home</a> | <span rel="v:child" typeof="v:Breadcrumb"><a href="http://zipo.co.ke/category/entertainment/" rel="v:url" property="v:title">Entertainment</a></span></p>
            <header>
                <h1 class="entry-title">Nairobi Diaries star Mishi Dora mourns death of partner</h1>

                                    <p class="td-post-sub-title">The business associate died in a gory road accident</p>
                

                <div class="meta-info">

                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://zipo.co.ke/author/pulselive/">PulseLive</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-14T13:16:29+00:00" >March 14, 2018</time></span>                                                        </div>
            </header>


        </div>

        <div class="td-post-sharing td-post-sharing-top td-pb-padding-side"><span class="td-post-share-title">SHARE</span>
				<div class="td-default-sharing ">
		            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fzipo.co.ke%2F31000%2Fnairobi-diaries-star-mishi-dora-mourns-death-partner%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-facebook"></div><div class="td-social-but-text">Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Nairobi+Diaries+star+Mishi+Dora+mourns+death+of+partner&url=http%3A%2F%2Fzipo.co.ke%2F31000%2Fnairobi-diaries-star-mishi-dora-mourns-death-partner%2F&via=Zipo_co_ke"  ><div class="td-sp td-sp-twitter"></div><div class="td-social-but-text">Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://zipo.co.ke/31000/nairobi-diaries-star-mishi-dora-mourns-death-partner/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-googleplus"></div></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://zipo.co.ke/31000/nairobi-diaries-star-mishi-dora-mourns-death-partner/&amp;media=http://zipo.co.ke/wp-content/uploads/2018/01/Mishi-Dora_BUZZCENTRAL.jpg" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-pinterest"></div></a>
	                <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Nairobi+Diaries+star+Mishi+Dora+mourns+death+of+partner%20-%20http%3A%2F%2Fzipo.co.ke%2F31000%2Fnairobi-diaries-star-mishi-dora-mourns-death-partner%2F" ><div class="td-sp td-sp-whatsapp"></div></a>
	                <div class="clearfix"></div>
	            </div></div>

        <div class="td-post-content td-pb-padding-side">

        <div class="td-post-featured-image"><figure><a href="http://zipo.co.ke/wp-content/uploads/2018/01/Mishi-Dora_BUZZCENTRAL.jpg" data-caption="Mishi Dora. PHOTO: BUZZCENTRAL"><img width="640" height="429" class="entry-thumb td-modal-image" src="http://zipo.co.ke/wp-content/uploads/2018/01/Mishi-Dora_BUZZCENTRAL-640x429.jpg" alt="Mishi Dora" title=""/></a><figcaption class="wp-caption-text">Mishi Dora. PHOTO: BUZZCENTRAL</figcaption></figure></div>
        <p><strong>Nairobi Diaries actress and socialite Mishi Dora is a sad woman after she lost her business partner and best friend in a nasty road accident.</strong></p>

 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1024 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="4848821928"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
                    if ( td_screen_width >= 768  && td_screen_width < 1024 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="4848821928"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="4848821928"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<p>According to Mishi who shared the news on her Instagram page, she was supposed to meet Brax her business partner who was also her hair dresser either on Wednesday or Thursday after he came back from Kisumu but that did not happen.</p>
<figure id="attachment_31003" style="max-width: 644px" class="wp-caption alignnone"><img class="size-full wp-image-31003" src="http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_business-partner_COURTESY.jpg" alt="Mishi Dora" width="644" height="355" srcset="http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_business-partner_COURTESY.jpg 644w, http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_business-partner_COURTESY-300x165.jpg 300w, http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_business-partner_COURTESY-640x353.jpg 640w" sizes="(max-width: 644px) 100vw, 644px" /><figcaption class="wp-caption-text">Mishi Dora with her business partner. PHOTO: COURTESY</figcaption></figure>
<p>This comes just a month after the mother of three lost her father whom she described as someone who always saw the best in her no matter what happened and always encouraged her to get the best for herself.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="http://zipo.co.ke/30756/bahati-warns-blog-writing-controversial-stories-bout/" target="_blank" rel="nofollow" class="u9a39bdc2fe80092f6314cba7c651d1bb"><!-- INLINE RELATED POSTS 1/3 //--><style> .u9a39bdc2fe80092f6314cba7c651d1bb { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#FFFFFF; border:0!important; border-left:4px solid #E67E22!important; text-decoration:none; } .u9a39bdc2fe80092f6314cba7c651d1bb:active, .u9a39bdc2fe80092f6314cba7c651d1bb:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u9a39bdc2fe80092f6314cba7c651d1bb { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u9a39bdc2fe80092f6314cba7c651d1bb .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u9a39bdc2fe80092f6314cba7c651d1bb .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .u9a39bdc2fe80092f6314cba7c651d1bb:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ:</span>&nbsp; <span class="postTitle">Bahati warns blog against writing controversial stories about his family</span></div></a></div><figure id="attachment_31002" style="max-width: 644px" class="wp-caption alignnone"><img class="size-full wp-image-31002" src="http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_PULSELIVE.jpg" alt="Mishi Dora" width="644" height="444" srcset="http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_PULSELIVE.jpg 644w, http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_PULSELIVE-300x207.jpg 300w, http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_PULSELIVE-609x420.jpg 609w, http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_PULSELIVE-640x441.jpg 640w" sizes="(max-width: 644px) 100vw, 644px" /><figcaption class="wp-caption-text">Reality star Mishi Dora. PHOTO: PULSELIVE</figcaption></figure>
<p>“Life!!! What is LIFE??&#8230;. so this guy who happens to be my business partner and a friend calls me yesterday to check on me since he heard that I was rushed to the hospital, I tell him I&#8217;m stable but can&#8217;t talk much still.. He cuts the line on me after telling me that he&#8217;d better see me at the spa on Wednesday or Thursday when he is back from Kisumu where he was headed to at that very moment he was speaking to me&#8230; He was to work on my hair since he is the one that colored it and made me believe that I can look good in different colours besides black.. So at 7pm last evening I get messages and pictures of him involved in a terrible accident and that he is dead.. How?? Just how I&#8217;m I gonna stop your voice from playing on my head?? Why Brax?? Why now my friend @tha_salonguybrax .. I can&#8217;t question God.. He knows best.. R.I.P bro nobody knows tomorrow #RIP #touchofstyle,” she said in her post.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="http://zipo.co.ke/30929/khaligraph-jones-responds-octopizzo-diss-sauti-sol-collab/" target="_blank" rel="nofollow" class="u512f7b9e11793aa1c29c4f94efa11d3e"><!-- INLINE RELATED POSTS 2/3 //--><style> .u512f7b9e11793aa1c29c4f94efa11d3e { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#FFFFFF; border:0!important; border-left:4px solid #E67E22!important; text-decoration:none; } .u512f7b9e11793aa1c29c4f94efa11d3e:active, .u512f7b9e11793aa1c29c4f94efa11d3e:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u512f7b9e11793aa1c29c4f94efa11d3e { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u512f7b9e11793aa1c29c4f94efa11d3e .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u512f7b9e11793aa1c29c4f94efa11d3e .postTitle { color:#000000; text-decoration: underline!important; font-size: 16px; } .u512f7b9e11793aa1c29c4f94efa11d3e:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ:</span>&nbsp; <span class="postTitle">Khaligraph Jones responds to Octopizzo diss with Sauti Sol collab</span></div></a></div>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="7153473526"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-6709196930072417"
     data-ad-slot="5771884724"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>

        </div>


        <footer>
                        
            <div class="td-post-source-tags td-pb-padding-side">
                <div class="td-post-source-via "><div class="td-post-small-box"><span>VIA</span><a rel="nofollow" href="http://www.pulselive.co.ke/entertainment/mishi-dora-loses-her-business-partner-in-a-road-accident-id8111911.html">PulseLive</a></div></div>                            </div>

                                    <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://zipo.co.ke/author/pulselive/">PulseLive</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="PulseLive"></span><meta itemprop="datePublished" content="2018-03-14T13:16:29+00:00"><meta itemprop="dateModified" content="2018-03-14T13:29:59+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://zipo.co.ke/31000/nairobi-diaries-star-mishi-dora-mourns-death-partner/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://zipo.co.ke/wp-content/uploads/2016/08/zpmbw.png"></span><meta itemprop="name" content="Zipo.co.ke"></span><meta itemprop="headline " content="Nairobi Diaries star Mishi Dora mourns death of partner"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://zipo.co.ke/wp-content/uploads/2018/01/Mishi-Dora_BUZZCENTRAL.jpg"><meta itemprop="width" content="700"><meta itemprop="height" content="469"></span>        </footer>

    </article> <!-- /.post -->

    <script>var block_td_uid_4_5aa909c50628a = new tdBlock();
block_td_uid_4_5aa909c50628a.id = "td_uid_4_5aa909c50628a";
block_td_uid_4_5aa909c50628a.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5aa909c50628a_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":31000,"live_filter_cur_post_author":"16"}';
block_td_uid_4_5aa909c50628a.td_column_number = "3";
block_td_uid_4_5aa909c50628a.block_type = "td_block_related_posts";
block_td_uid_4_5aa909c50628a.post_count = "3";
block_td_uid_4_5aa909c50628a.found_posts = "89";
block_td_uid_4_5aa909c50628a.header_color = "";
block_td_uid_4_5aa909c50628a.ajax_pagination_infinite_stop = "";
block_td_uid_4_5aa909c50628a.max_num_pages = "30";
tdBlocksArray.push(block_td_uid_4_5aa909c50628a);
</script><div class="td_block_wrap td_block_related_posts td_uid_4_5aa909c50628a_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5aa909c50628a" ><h4 class="td-related-title"><a id="td_uid_5_5aa909c507f31" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_4_5aa909c50628a" href="#">RELATED ARTICLES</a><a id="td_uid_6_5aa909c507f6d" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_4_5aa909c50628a" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_4_5aa909c50628a class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://zipo.co.ke/30708/meet-hunk-socialite-mishi-doras-life-photo/" rel="bookmark" title="Meet the hunk in socialite Mishi Dora&#8217;s life [PHOTO]"><img width="238" height="178" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2018/03/Mishi-Dora_KENYANNEWS-s-238x178.jpg" alt="Mishi Dora" title="Meet the hunk in socialite Mishi Dora&#8217;s life [PHOTO]"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/30708/meet-hunk-socialite-mishi-doras-life-photo/" rel="bookmark" title="Meet the hunk in socialite Mishi Dora&#8217;s life [PHOTO]">Meet the hunk in socialite Mishi Dora&#8217;s life [PHOTO]</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://zipo.co.ke/30165/kalekye-mumo-slams-fans-asking-cover-arms-photo/" rel="bookmark" title="Kalekye Mumo slams fans for asking her to cover her arms [PHOTO]"><img width="238" height="178" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2017/01/kalekye-mumo_UDAKUNEWS-238x178.jpg" alt="kalekye mumo" title="Kalekye Mumo slams fans for asking her to cover her arms [PHOTO]"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/30165/kalekye-mumo-slams-fans-asking-cover-arms-photo/" rel="bookmark" title="Kalekye Mumo slams fans for asking her to cover her arms [PHOTO]">Kalekye Mumo slams fans for asking her to cover her arms [PHOTO]</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://zipo.co.ke/30147/3-family-members-die-magina-accident-along-nakuru-nairobi-highway/" rel="bookmark" title="3 family members die in Magina accident along Nakuru-Nairobi highway"><img width="238" height="178" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2018/02/Accident_COURTESY-238x178.jpg" alt="Accident_ahead" title="3 family members die in Magina accident along Nakuru-Nairobi highway"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/30147/3-family-members-die-magina-accident-along-nakuru-nairobi-highway/" rel="bookmark" title="3 family members die in Magina accident along Nakuru-Nairobi highway">3 family members die in Magina accident along Nakuru-Nairobi highway</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5aa909c50628a" data-td_block_id="td_uid_4_5aa909c50628a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5aa909c50628a" data-td_block_id="td_uid_4_5aa909c50628a"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

<div id="disqus_thread"></div>
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1024 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="4200007129"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
                    if ( td_screen_width >= 768  && td_screen_width < 1024 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6709196930072417" data-ad-slot="4200007129"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<div class="td_block_wrap td_block_7 td_block_widget td_uid_8_5aa909c509e41_rand td-pb-border-top"  data-td-block-uid="td_uid_8_5aa909c509e41" >
<style scoped>
.td_uid_8_5aa909c509e41_rand .td_module_wrap:hover .entry-title a,
            .td_uid_8_5aa909c509e41_rand .td-load-more-wrap a:hover,
        	.td_uid_8_5aa909c509e41_rand .td_quote_on_blocks,
        	.td_uid_8_5aa909c509e41_rand .td-wrapper-pulldown-filter .td-pulldown-filter-display-option:hover,
        	.td_uid_8_5aa909c509e41_rand .td-wrapper-pulldown-filter a.td-pulldown-filter-link:hover,
        	.td_uid_8_5aa909c509e41_rand .td-instagram-user a {
                color: #ff5511;
            }

            .td_uid_8_5aa909c509e41_rand .td-next-prev-wrap a:hover i {
                background-color: #ff5511;
                border-color: #ff5511;
            }

            .td_uid_8_5aa909c509e41_rand .td_module_wrap .td-post-category:hover,
			.td_uid_8_5aa909c509e41_rand .td-trending-now-title,
            .td_uid_8_5aa909c509e41_rand .block-title span,
            .td_uid_8_5aa909c509e41_rand .td-weather-information:before,
            .td_uid_8_5aa909c509e41_rand .td-weather-week:before,
            .td_uid_8_5aa909c509e41_rand .td-exchange-header:before,
            .td_uid_8_5aa909c509e41_rand .block-title a {
                background-color: #ff5511;
            }

            
            .td_uid_8_5aa909c509e41_rand .td-trending-now-title,
            .td_uid_8_5aa909c509e41_rand .block-title span,
            .td_uid_8_5aa909c509e41_rand .block-title a {
                color: #;
            }
</style><script>var block_td_uid_8_5aa909c509e41 = new tdBlock();
block_td_uid_8_5aa909c509e41.id = "td_uid_8_5aa909c509e41";
block_td_uid_8_5aa909c509e41.atts = '{"limit":"4","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"58","category_ids":"","custom_title":"LATEST NEWS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#ff5511","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_8_5aa909c509e41_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_8_5aa909c509e41.td_column_number = "1";
block_td_uid_8_5aa909c509e41.block_type = "td_block_7";
block_td_uid_8_5aa909c509e41.post_count = "4";
block_td_uid_8_5aa909c509e41.found_posts = "1821";
block_td_uid_8_5aa909c509e41.header_color = "#ff5511";
block_td_uid_8_5aa909c509e41.ajax_pagination_infinite_stop = "";
block_td_uid_8_5aa909c509e41.max_num_pages = "456";
tdBlocksArray.push(block_td_uid_8_5aa909c509e41);
</script><h4 class="block-title"><span>LATEST NEWS</span></h4><div id=td_uid_8_5aa909c509e41 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="http://zipo.co.ke/31014/heavily-pregnant-singer-avril-slams-online-haters-badly/" rel="bookmark" title="Heavily pregnant singer Avril slams online haters, badly"><img width="100" height="75" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2018/03/Avril-Nyambura_phone_IG-100x75.jpg" alt="Avril_kenya" title="Heavily pregnant singer Avril slams online haters, badly"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/31014/heavily-pregnant-singer-avril-slams-online-haters-badly/" rel="bookmark" title="Heavily pregnant singer Avril slams online haters, badly">Heavily pregnant singer Avril slams online haters, badly</a></h3>            <div class="meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="http://zipo.co.ke/31011/akothee-begs-fans-pray-amidst-tough-child-custody-court-battle/" rel="bookmark" title="Akothee begs fans to pray for her amidst tough child custody battle"><img width="100" height="75" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2016/12/Akothe_KISSFM-100x75.jpg" alt="akothee" title="Akothee begs fans to pray for her amidst tough child custody battle"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/31011/akothee-begs-fans-pray-amidst-tough-child-custody-court-battle/" rel="bookmark" title="Akothee begs fans to pray for her amidst tough child custody battle">Akothee begs fans to pray for her amidst tough child custody battle</a></h3>            <div class="meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="http://zipo.co.ke/31008/meet-comedian-mc-jessys-handsome-son-photo/" rel="bookmark" title="Meet comedian MC Jessy&#8217;s handsome son [PHOTO]"><img width="100" height="75" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2017/05/MC-JESSY_NAIBUZZ-100x75.jpg" alt="MC JESSY" title="Meet comedian MC Jessy&#8217;s handsome son [PHOTO]"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/31008/meet-comedian-mc-jessys-handsome-son-photo/" rel="bookmark" title="Meet comedian MC Jessy&#8217;s handsome son [PHOTO]">Meet comedian MC Jessy&#8217;s handsome son [PHOTO]</a></h3>            <div class="meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="http://zipo.co.ke/31005/julie-gichuru-congratulates-new-dpp-deletes-tweet-immediately/" rel="bookmark" title="Julie Gichuru congratulates new DPP then deletes tweet immediately. Why?"><img width="100" height="75" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2017/12/Julie-Gichuru_COURTESY-100x75.jpg" alt="Julie Gichuru" title="Julie Gichuru congratulates new DPP then deletes tweet immediately. Why?"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/31005/julie-gichuru-congratulates-new-dpp-deletes-tweet-immediately/" rel="bookmark" title="Julie Gichuru congratulates new DPP then deletes tweet immediately. Why?">Julie Gichuru congratulates new DPP then deletes tweet immediately. Why?</a></h3>            <div class="meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><div class="td_block_wrap td_block_7 td_block_widget td_uid_9_5aa909c50f5e9_rand td-pb-border-top"  data-td-block-uid="td_uid_9_5aa909c50f5e9" >
<style scoped>
.td_uid_9_5aa909c50f5e9_rand .td_module_wrap:hover .entry-title a,
            .td_uid_9_5aa909c50f5e9_rand .td-load-more-wrap a:hover,
        	.td_uid_9_5aa909c50f5e9_rand .td_quote_on_blocks,
        	.td_uid_9_5aa909c50f5e9_rand .td-wrapper-pulldown-filter .td-pulldown-filter-display-option:hover,
        	.td_uid_9_5aa909c50f5e9_rand .td-wrapper-pulldown-filter a.td-pulldown-filter-link:hover,
        	.td_uid_9_5aa909c50f5e9_rand .td-instagram-user a {
                color: #000000;
            }

            .td_uid_9_5aa909c50f5e9_rand .td-next-prev-wrap a:hover i {
                background-color: #000000;
                border-color: #000000;
            }

            .td_uid_9_5aa909c50f5e9_rand .td_module_wrap .td-post-category:hover,
			.td_uid_9_5aa909c50f5e9_rand .td-trending-now-title,
            .td_uid_9_5aa909c50f5e9_rand .block-title span,
            .td_uid_9_5aa909c50f5e9_rand .td-weather-information:before,
            .td_uid_9_5aa909c50f5e9_rand .td-weather-week:before,
            .td_uid_9_5aa909c50f5e9_rand .td-exchange-header:before,
            .td_uid_9_5aa909c50f5e9_rand .block-title a {
                background-color: #000000;
            }

            
            .td_uid_9_5aa909c50f5e9_rand .td-trending-now-title,
            .td_uid_9_5aa909c50f5e9_rand .block-title span,
            .td_uid_9_5aa909c50f5e9_rand .block-title a {
                color: #;
            }
</style><script>var block_td_uid_9_5aa909c50f5e9 = new tdBlock();
block_td_uid_9_5aa909c50f5e9.id = "td_uid_9_5aa909c50f5e9";
block_td_uid_9_5aa909c50f5e9.atts = '{"limit":"3","sort":"random_posts","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"58","category_ids":"","custom_title":"EDITOR\u0027S PICKS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#000000","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_9_5aa909c50f5e9_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_9_5aa909c50f5e9.td_column_number = "1";
block_td_uid_9_5aa909c50f5e9.block_type = "td_block_7";
block_td_uid_9_5aa909c50f5e9.post_count = "3";
block_td_uid_9_5aa909c50f5e9.found_posts = "1821";
block_td_uid_9_5aa909c50f5e9.header_color = "#000000";
block_td_uid_9_5aa909c50f5e9.ajax_pagination_infinite_stop = "";
block_td_uid_9_5aa909c50f5e9.max_num_pages = "607";
tdBlocksArray.push(block_td_uid_9_5aa909c50f5e9);
</script><h4 class="block-title"><span>EDITOR&#039;S PICKS</span></h4><div id=td_uid_9_5aa909c50f5e9 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="http://zipo.co.ke/3653/newly-wed-nyota-ndogo-pregnant-third-child/" rel="bookmark" title="Newly-wed Nyota Ndogo is pregnant with third child"><img width="100" height="75" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2016/06/nyota-ndogo-nielson-100x75.jpg" alt="nyota ndogo-nielson" title="Newly-wed Nyota Ndogo is pregnant with third child"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/3653/newly-wed-nyota-ndogo-pregnant-third-child/" rel="bookmark" title="Newly-wed Nyota Ndogo is pregnant with third child">Newly-wed Nyota Ndogo is pregnant with third child</a></h3>            <div class="meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="http://zipo.co.ke/28151/video-femi-one-luku-luku-ft-kristoff/" rel="bookmark" title="VIDEO: Femi One &#8216;Luku Luku&#8217; ft Kristoff"><img width="100" height="75" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2017/12/Femi-One_IG-100x75.jpg" alt="Femi One" title="VIDEO: Femi One &#8216;Luku Luku&#8217; ft Kristoff"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/28151/video-femi-one-luku-luku-ft-kristoff/" rel="bookmark" title="VIDEO: Femi One &#8216;Luku Luku&#8217; ft Kristoff">VIDEO: Femi One &#8216;Luku Luku&#8217; ft Kristoff</a></h3>            <div class="meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="http://zipo.co.ke/25666/nyota-ndogo-humongous-house-gift-mum-excites-fans-photo/" rel="bookmark" title="Nyota Ndogo humongous house gift to mum excites fans [PHOTO]"><img width="100" height="75" class="entry-thumb" src="http://zipo.co.ke/wp-content/uploads/2017/10/Nyota-Ndogo_INSTAGRAM-1-100x75.jpg" alt="Nyota Ndogo" title="Nyota Ndogo humongous house gift to mum excites fans [PHOTO]"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://zipo.co.ke/25666/nyota-ndogo-humongous-house-gift-mum-excites-fans-photo/" rel="bookmark" title="Nyota Ndogo humongous house gift to mum excites fans [PHOTO]">Nyota Ndogo humongous house gift to mum excites fans [PHOTO]</a></h3>            <div class="meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </div>
    </div> <!-- /.td-container -->

    <!-- Instagram -->
    

    <!-- Footer -->
    <div class="td-footer-container td-container">

	<div class="td-pb-row">
		<div class="td-pb-span12">
					</div>
	</div>

	<div class="td-pb-row">
		<div class="td-pb-span12 td-footer-full">
			<div class="td-footer-info td-pb-padding-side"><div class="footer-logo-wrap"><a href="http://zipo.co.ke/"><img src="http://zipo.co.ke/wp-content/uploads/2017/10/nmff.jpg" alt="ZIPO.co.ke" title=""/></a></div><div class="footer-text-wrap">ZIPO.co.ke</div><div class="footer-social-wrap td-social-style2"></div></div>		</div>
		<div class="td-pb-span12">
					</div>
	</div>
</div>

    <!-- Sub Footer -->
            <div class="td-sub-footer-container td-container td-container-border ">
            <div class="td-pb-row">
                <div class="td-pb-span8 td-sub-footer-menu">
                    <div class="td-pb-padding-side">
                        <div class="menu-ftmenu-container"><ul id="menu-ftmenu" class="td-subfooter-menu"><li id="menu-item-239" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-239"><a href="http://zipo.co.ke/contact-us/">Contact Us</a></li>
<li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-240"><a href="http://zipo.co.ke/about-us/">About Us</a></li>
</ul></div>                    </div>
                </div>

                <div class="td-pb-span4 td-sub-footer-copy">
                    <div class="td-pb-padding-side">
                        &copy; 2017 Zipo.co.ke. All Rights Reserved                    </div>
                </div>
            </div>
        </div>
        </div><!--close td-outer-container-->
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newsmag by tagDiv 2016
        Version: 3.1 (rara)
        Deploy mode: deploy
        Speed booster: v4.5

        uid: 5aa909c5177ff
    -->

    <script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"zipo"};
/* ]]> */
</script>
<script type='text/javascript' src='http://zipo.co.ke/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"31000 http:\/\/zipo.co.ke\/?p=31000","disqusShortname":"zipo","disqusTitle":"Nairobi Diaries star Mishi Dora mourns death of partner","disqusUrl":"http:\/\/zipo.co.ke\/31000\/nairobi-diaries-star-mishi-dora-mourns-death-partner\/","postId":"31000"};
/* ]]> */
</script>
<script type='text/javascript' src='http://zipo.co.ke/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script>
<script type='text/javascript' src='http://zipo.co.ke/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=3.1'></script>
<script type='text/javascript' src='http://zipo.co.ke/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://zipo.co.ke/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://zipo.co.ke/wp-content/themes/Newsmag/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://zipo.co.ke/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


<!-- Header style compiled by theme -->

<style>
    
.td-header-sp-top-menu .top-header-menu > li > a,
    .td-header-sp-top-menu .td_data_time,
    .td-header-sp-top-menu .td-weather-top-widget {
        color: #ffffff;
    }

    
    .td-header-main-menu {
        background-color: #000000;
    }

    
    .sf-menu > li > a,
    .header-search-wrap .td-icon-search,
    #td-top-mobile-toggle i {
        color: #e2e2e2;
    }

    
    @media (max-width: 767px) {
        body .td-header-wrap .td-header-main-menu {
            background-color: #000000;
        }
    }

    
    @media (max-width: 767px) {
        body #td-top-mobile-toggle i,
        .td-header-wrap .header-search-wrap .td-icon-search {
            color: #e2e2e2 !important;
        }
    }

    
    .td-footer-container,
    .td-footer-container .td_module_mx3 .meta-info,
    .td-footer-container .td_module_14 .meta-info,
    .td-footer-container .td_module_mx1 .td-block14-border {
        background-color: #000000;
    }
    .td-footer-container .widget_calendar #today {
    	background-color: transparent;
    }
</style>


</body>
</html>